add dependency on apache2 (>= 2.2.4) because of the new
authorDamyan Ivanov <dmn@debian.org>
Sat, 25 Oct 2008 12:58:00 +0000 (12:58 +0000)
committerDamyan Ivanov <dmn@debian.org>
Sat, 25 Oct 2008 12:58:00 +0000 (12:58 +0000)
ap_get_server_banner symbol not available in previous apaches
Closes: #503375: libapache2-mod-perl2 - Uses undefined symbol
ap_get_server_banner
Thanks to Bastian Blank for reporting.

debian/changelog
debian/control

index 8f49a24..446bfaf 100644 (file)
@@ -1,4 +1,4 @@
-libapache2-mod-perl2 (2.0.4-4) UNRELEASED; urgency=low
+libapache2-mod-perl2 (2.0.4-4) UNRELEASED; urgency=medium
 
     WAIT FOR -3 to hit lenny
 
@@ -11,6 +11,13 @@ libapache2-mod-perl2 (2.0.4-4) UNRELEASED; urgency=low
   * Add debian/README.source to document quilt usage, as required by
     Debian Policy since 3.8.0.
 
+  [ Damyan Ivanov ]
+  * add dependency on apache2 (>= 2.2.4) because of the new
+    ap_get_server_banner symbol not available in previous apaches
+    Closes: #503375: libapache2-mod-perl2 - Uses undefined symbol
+                     ap_get_server_banner
+    Thanks to Bastian Blank for reporting.
+
  -- Frank Lichtenheld <djpig@debian.org>  Wed, 06 Aug 2008 20:12:39 -0300
 
 libapache2-mod-perl2 (2.0.4-3) unstable; urgency=low
index 95cce2f..3970642 100644 (file)
@@ -19,7 +19,8 @@ Build-Conflicts: libapache2-mod-perl2 (<= 1.999.22-1)
 Package: libapache2-mod-perl2
 Architecture: any
 Depends: apache2.2-common, ${perl:Depends}, libwww-perl, libmime-base64-perl,
- libdevel-symdump-perl, liburi-perl, ${shlibs:Depends}, netbase
+ libdevel-symdump-perl, liburi-perl, ${shlibs:Depends}, netbase,
+ apache2 (>= 2.2.4)
 Recommends: libbsd-resource-perl, libapache2-reload-perl
 Description: Integration of perl with the Apache2 web server
  mod_perl allows the use of Perl for just about anything