* add explicit build-dependency on libcgi-pm-perl (>= 3.33) as the version
authorDamyan Ivanov <dmn@debian.org>
Mon, 11 Aug 2008 08:07:33 +0000 (08:07 +0000)
committerDamyan Ivanov <dmn@debian.org>
Mon, 11 Aug 2008 08:07:33 +0000 (08:07 +0000)
  of CGI.pm shipped in perl-modules fails with a taint failure when handling
  uploads. Thanks to Niko Tyni for the investigation.
  Closes: #480154 -- FTBFS on mips (cgiupload tests fail)
  - bump urgency to medium

debian/changelog
debian/control

index ee5670d..d1995b2 100644 (file)
@@ -1,4 +1,4 @@
-libapache2-mod-perl2 (2.0.4-2) UNRELEASED; urgency=low
+libapache2-mod-perl2 (2.0.4-2) UNRELEASED; urgency=medium
 
   [ Frank Lichtenheld ]
   * Convert debian/copyright to proposed new format.
@@ -9,6 +9,13 @@ libapache2-mod-perl2 (2.0.4-2) UNRELEASED; urgency=low
   * Add debian/README.source to document quilt usage, as required by
     Debian Policy since 3.8.0.
 
+  [ Damyan Ivanov ]
+  * add explicit build-dependency on libcgi-pm-perl (>= 3.33) as the version
+    of CGI.pm shipped in perl-modules fails with a taint failure when handling
+    uploads. Thanks to Niko Tyni for the investigation.
+    Closes: #480154 -- FTBFS on mips (cgiupload tests fail)
+    - bump urgency to medium
+
  -- Frank Lichtenheld <djpig@debian.org>  Wed, 06 Aug 2008 20:12:39 -0300
 
 libapache2-mod-perl2 (2.0.4-1) unstable; urgency=low
index a8231d5..be46458 100644 (file)
@@ -12,7 +12,7 @@ Build-Depends: perl (>= 5.8.7-3), libperl-dev (>= 5.8.7-3),
  apache2-threaded-dev (>= 2.2.3) | apache2-prefork-dev (>= 2.2.3),
  debhelper (>= 6), libwww-perl, libdevel-symdump-perl, libhtml-parser-perl,
  libgdbm-dev, libgtop2-dev, quilt, apache2, libcompress-zlib-perl,
- libbsd-resource-perl, locales-all, netbase
+ libbsd-resource-perl, locales-all, netbase, libcgi-pm-perl (>= 3.33)
 Build-Conflicts: libapache2-mod-perl2 (<= 1.999.22-1)
 
 Package: libapache2-mod-perl2