fc46ae7a0212a4a496e8022c14cc88436a4d39c4
[debian-science/packages/sagelib.git] / debian / control
1 Source: sagelib
2 Section: math
3 Priority: optional
4 Maintainer: Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
5 Uploaders: Felix Salfelder <felix@salfelder.org>
6 Build-Depends: debhelper (>= 9)
7 Standards-Version: 3.9.4
8 X-Python-Version: 2.7
9
10 # some tests will fail with python-matplotlib <=1.2.1
11
12 Package: sagelib-builddeps-testing
13 Architecture: all
14 Description: build dependencies of sagelib that are in Debian testing
15  This meta-package depends on all build dependencies of sagelib
16  that are currently in Debian testing.
17 Depends:
18  ${misc:Depends},
19  cython (>= 0.19),
20  debhelper (>= 7),
21  dpkg-dev (>= 1.15.7~),
22  ecl (>= 11),
23  eclib-tools,
24  f2c,
25  gap (>= 4r6p4),
26  gap-dev (>= 4r6p5-3),
27  gfan,
28  ipython,
29  lcalc (>= 0.0.20080205-2),
30  libatlas-base-dev,
31  libblas-dev,
32  libcdd-dev (>= 094g-4),
33  libcliquer-dev,
34  libec-dev (>= 0.0.2012.02.01),
35  libecm-dev,
36  libfplll-dev,
37  libfreetype6-dev,
38  libgc-dev,
39  libgcrypt11-dev,
40  libgd2-noxpm-dev | libgd2-xpm-dev,
41  libgivaro-dev (= 3.7.2-1),
42  libglpk-dev,
43  libgmp-dev (>= 2:5.1.2),
44  libgnutls-dev,
45  libgpg-error-dev,
46  libgsl0-dev,
47  libiml-dev,
48  liblapack-dev,
49  liblfunction-dev,
50  liblrcalc-dev,
51  libm4ri-dev (>= 20130416),
52  libm4rie-dev (>= 20130416),
53  libmpc-dev (>=1.0),
54  libmpfi-dev,
55  libmpfr-dev,
56  libntl-dev,
57  libpng12-dev,
58  libpolybori-dev (>= 0.8.0),
59  libpolybori-groebner-dev,
60  libppl0.12-dev (>= 1:1.1),
61  libpynac-dev (>= 0.2.6-1),
62  libratpoints-dev,
63  libreadline-dev,
64  libsqlite3-dev,
65  libsymmetrica-dev,
66  libtachyon-dev,
67  libzn-poly-dev,
68  maxima,
69  palp (>= 2.1-2),
70  python2.7-dev,
71  python-crypto,
72  python-cvxopt,
73  python-docutils,
74  python-gnutls,
75  python-matplotlib,
76  python-moinmoin,
77  python-mpmath,
78  python-networkx,
79  python-numpy,
80  python-ply,
81  python-pygments,
82  python-rpy2,
83  python-scipy,
84  python-setuptools,
85  python-sphinx,
86  python-sqlalchemy,
87  python-sympy,
88  python-twisted,
89  python-zodb,
90  r-cran-lattice,
91  r-base-dev,
92  sagemath-database-conway-polynomials,
93  sagemath-database-elliptic-curves,
94  sagemath-database-graphs,
95  sagemath-database-polytopes,
96  scons,
97  sqlite3,
98  sympow,
99  tachyon,
100  zlib1g-dev
101
102 Package: sagelib-builddeps-unstable
103 Architecture: all
104 Description: build dependencies of sagelib that are in Debian unstable
105  This meta-package depends on all build dependencies of sagelib
106  that are currently in Debian unstable, but not in testing.
107 Depends:
108  ${misc:Depends},
109  liblinboxsage-dev (>= 1.3.2)
110
111 Package: sagelib-builddeps-experimental
112 Architecture: all
113 Description: build dependencies of sagelib that are in Debian experimental
114  This meta-package depends on all build dependencies of sagelib
115  that are currently in Debian experimental, but not in unstable or testing.
116 Depends:
117  ${misc:Depends}
118
119 Package: sagelib-builddeps-git
120 Architecture: all
121 Description: build dependencies of sagelib that are not in Debian
122  This meta-package depends on all build dependencies of sagelib
123  that are currently not in Debian at all. Most of them should be 
124  packaged in the Debian Science git at
125  http://anonscm.debian.org/gitweb/?a=project_list&s=debian-science%2Fpackages
126 Depends:
127  ${misc:Depends},
128  libsingular-dev (>= 3-1-6),
129  libflint-dev (>= 2.3),
130  libpari-dev (>= 2.4),
131  python-pexpect-2.0,
132  python-sagenb (>= 0.10.4),
133  rubiks