summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--t/COVERAGE2
-rw-r--r--t/tests/debhelper-lacks-versioned-deps/debian/debian/compat1
-rw-r--r--t/tests/debhelper-lacks-versioned-deps/debian/debian/control.in15
-rw-r--r--t/tests/debhelper-lacks-versioned-deps/desc7
-rw-r--r--t/tests/debhelper-lacks-versioned-deps/tags1
5 files changed, 24 insertions, 2 deletions
diff --git a/t/COVERAGE b/t/COVERAGE
index d8de3fe..35826d5 100644
--- a/t/COVERAGE
+++ b/t/COVERAGE
@@ -212,7 +212,6 @@ debconf using-first-person-in-templates
debconf using-imperative-form-in-templates
debconf using-question-in-extended-description-in-templates
-debhelper package-lacks-versioned-build-depends-on-debhelper
debhelper uses-dh-python-with-no-pycompat
fields build-depends-indep-without-arch-indep
@@ -475,7 +474,6 @@ libbaz
maintainer-shell-script-fails-syntax-check
missing-dependency-on-perlapi
missing-depends-line
- package-lacks-versioned-build-depends-on-debhelper
package-name-doesnt-match-sonames
postinst-should-not-set-usr-doc-link
shlib-with-executable-bit
diff --git a/t/tests/debhelper-lacks-versioned-deps/debian/debian/compat b/t/tests/debhelper-lacks-versioned-deps/debian/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/t/tests/debhelper-lacks-versioned-deps/debian/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/t/tests/debhelper-lacks-versioned-deps/debian/debian/control.in b/t/tests/debhelper-lacks-versioned-deps/debian/debian/control.in
new file mode 100644
index 0000000..e296972
--- /dev/null
+++ b/t/tests/debhelper-lacks-versioned-deps/debian/debian/control.in
@@ -0,0 +1,15 @@
+Source: {$srcpkg}
+Priority: extra
+Section: {$section}
+Maintainer: {$author}
+Standards-Version: {$standards_version}
+Build-Depends: debhelper
+
+Package: {$srcpkg}
+Architecture: {$architecture}
+Depends: $\{misc:Depends\}
+Description: {$description}
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
diff --git a/t/tests/debhelper-lacks-versioned-deps/desc b/t/tests/debhelper-lacks-versioned-deps/desc
new file mode 100644
index 0000000..ae51574
--- /dev/null
+++ b/t/tests/debhelper-lacks-versioned-deps/desc
@@ -0,0 +1,7 @@
+Testname: debhelper-lacks-versioned-deps
+Sequence: 6000
+Version: 1.0
+Description: Test pedantic dependency requirements for debhelper
+Options: -I -E --pedantic
+Test-For:
+ package-lacks-versioned-build-depends-on-debhelper
diff --git a/t/tests/debhelper-lacks-versioned-deps/tags b/t/tests/debhelper-lacks-versioned-deps/tags
new file mode 100644
index 0000000..7d541ab
--- /dev/null
+++ b/t/tests/debhelper-lacks-versioned-deps/tags
@@ -0,0 +1 @@
+P: debhelper-lacks-versioned-deps source: package-lacks-versioned-build-depends-on-debhelper 7